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Introduction 
 
Overview 
Octopus USB Controller (OUC) is a unique utility which facilitates interfacing and configuration of a 
variety USB control devices on a Windows-based computer.  This application has many unique features 
including: 

• Compatibility with most commonly used USB Human Interface Devices (HID) with buttons, keys, 
or pedals, including those listed below (see full list of compatible devices at the end of this 
guide): 

o all SpeechWare devices (i.e. TableMikes) 
o a variety of hand-held USB microphones, including those made by Dictaphone/Nuance, 

Grundig, Olympus and Philips 
o most commonly available USB foot pedals 
o all commonly marketed USB keypads 

• Ability to simultaneously control multiple USB devices (multi-device awareness) 
• Support for “hot swapping”; i.e. connection or exchange of peripherals on the fly without 

restarting the application 
• Extremely intuitive user interface facilitating ease of use 
• Exporting and importing of device profile to facilitate sharing of device settings 
• Advantage of having a single interface with all the supported devices to facilitate ease of use 

across large organizations 
• “Learning” feature for unknown or non-supported devices 

 

Three versions 
 
Octopus USB Controller comes in 3 versions, depending upon your needs.  Here is a brief overview: 
 

• Standard OUC:  This is the original ground-breaking utility which includes all the standard 
functionality.   It does not include the unique keyset programming found in the legal version and 
intended to be of special use to attorineis.  The majority of this User Guide pertains to the 
standard version.   

• Legal OUC:  The recently released OUC Legal version is similar in most ways to the standard 
version and includes all functionality of the standard version, but includes a unique “Legal 
Keyset” which allows programming of keys on the standard or accessory keyboard to a variety of 
functions helpful to the practicing attorney 

• TableMike Configuration Utility:  Similar to the standard OUC version, this utility is provided for 
free for use with SpeechWare TableMikes and allows programming of the buttons on TableMike 
to accomplish all the functions seen with the Standard OUC.  It does not allow programming USB 
devices other than the TableMike (hand-held mics, foot pedals, accessory keypads, etc.) 
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Programming Options 
 
Using this control application, you can initiate a variety of actions with applications on virtually all recent 
vintage Windows operating system, including: 
 

• Inserting blocks of predefined “boilerplate” text  
• Pressing a keyboard key or key combination with your hand-held USB microphones and/or USB 

foot pedals 
• Emulating a variety of native Dragon NaturallySpeaking commands 
• Emulating any user-defined Dragon NaturallySpeaking command 
• Initiating a variety of Dragon hot-keys 
• Opening any application, document, folder or web page 
• Initiating a number of operating system functions such as opening Task Manager, moving 

through applications on the desktop, clearing the desktop and more. 
• Programming separate functions to the pressing and releasing of a key, button or lever 
• Executing sequential repetitive custom scripts involving consecutive steps involving any of the 

above functions 
 

Compatibility  
 
Operating Systems:  Octopus Control Utility is compatible with most common Windows operating 
systems, including Windows XP, Vista,7, 8 and 10 (including Windows 10 Anniversary Edition.) 
 
USB Devices Compatibility:  A list of currently compatible devices shows up in the “Active USB HID 
Device” drop-down in the main OUC window.  Also see a list of currently compatible devices in the 
appendix of this User Guide.  Realize, however, that this list is constantly growing.  For an updated list of 
currently compatible devices, also visit http://www.tablemike.com/en/download-applications.php or 
http://www.USBController.com  In addition, the user has the option of initiating a unique device 
“learning” feature for non-supported devices. 
 
Keypad Compatibility:  to date, all commonly marketed USB keypads have been found to be compatible 
with OUC.  
 

Installation/Licensing/Activation 
 
Installation:  Octopus Control Utility is installed by download from the Internet.  Visit 
https://www.tablemike.com/applications/#Octopus  and scroll to the section of Octopus USB Controller.  
Installation is straightforward and involves the following steps:  

http://www.tablemike.com/en/download-applications.php
http://www.usbcontroller.com/
https://www.tablemike.com/applications/#Octopus
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• Download the application from the link provided by your 
reseller, from SpeechWare, or from 
OctopusUSBController.com.  The application comes as a 
compressed zip file of about 8 MB in size 

• Unzip the downloaded file by right-clicking on it and 
selecting “Extract Files” or “Extract Here” (select Extract 
Files if you want to navigate to the location at which they 
will be extracted and select Extract Here if you want to 
extract and locate the final installation file in their current 
location.) 

• Click on the icon labeled “Setup”   
• Follow all subsequent instructions (installation takes less than 1 minute) 
• If you have purchased an activation code, this is a good time to activate your product (see 

instructions below) 
 

Activation: 
 
Trial Use:  OUC can be used on a trial basis for 3 instances before formal licensing and activation is 
required. 

 
Entering an activation code:  if you purchased your copy of OUC it should have been accompanied by an 
activation code.  This code can be entered as follows:  
 

• Navigate to Help > License activation ….   
• On the window that shows up, click on “License Activation” 
• On the following screen enter all the requested information, including your activation code. An 

internet connection will be necessary to 
complete the activation process.  (If you are 
lacking an internet connection, see the section 
below on “Telephone Activation”) 

• Click on “Activate” 
 

If you downloaded a trial version of OUC, you will need 
to purchase an activation code to use the product after 
the initial 3 free uses have ended. If you obtained the 
download from the Octopus USB Controller website, you can find a list of current OUC resellers on this 
site: (www.OctopusUSBController.com).  
 

http://www.octopususbcontroller.com/
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Telephone activation:  If your computer does not have 
an internet connection, the following procedure is used 
to generate a unique “Client Identification Number” 
which can be provided to your reseller by telephone 
and lead to provision of a “telephone activation code”. 
 

1. Proceed through the usual activation process 
by navigating to Help > License activation data 
as detailed in the section above. 

2. Fill in your name and email address 
3. Click on the “License Activation” 

 button 
4. On the subsequent “Internet License 

Activation” window click on the link on the 
bottom left labeled “Click here if there is NO 
Internet Access” 

5. On the next screen you will be provided with a 
“Client ID” which you should provide to your 
reseller by telephone or email.  Shortly 
thereafter you should receive a telephone 
activation code from your reseller.  This should 
be entered in the Telephone License Activation 
window as shown below: 
 

 
 

6. Click on the “Activate” button to complete the process. 
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Upgrades:  During the period in which you are eligible for free upgrades (2 years from time of initial 
license activation), when upgrades become available you will be automatically notified of this upon 
opening OUC and will be given the option of downloading the update immediately.  Alternatively, you 
can check for the availability of updates by navigating to Help > Update.  Either way, you will be walked 
through the updating process.   
 
If an update cannot be accomplished this may be a result of not having administrative privileges on your 
computer.  In such cases, we recommend that you follow this procedure: 
 

• Click the “cancel” button if necessary to end the update process 
• Close OUC 
• Find OUC from the Windows Start menu (All Programs > SpeechWare > Octopus USB 

Controller 
• Right click on Octopus USB Controller and select “Properties” and go to the “Compatibility” 

tab. 
• Check the box “Run this program as an administrator” and click the “Apply” button 
• Re-launch OUC and re-start the update procedure 

 
Licensing:  Standard OUC licensing allows use on two computers and is accompanied by free upgrades 
and support for a period of 2 years.  After this two-year period, it shall be necessary to purchase a new 
activation code which is generally available at a discount. 
 
Transferring a license:  If you need to move OUC from one computer to another, it is necessary to 
complete a formal uninstall on the one computer before installing and activating it on the second 
computer.  The following procedure is recommended in order for you to receive “credit” for the 
uninstall: 
 

• If you don’t have your activation code, identify this from the License Activation Data function 
described and imaged above (navigate to Help > License activation data) 

• Write down the activation code (remember that a zero is thin (0) and the letter “O” is more 
rounded.) 

• Formally uninstall the application by going to the Programs and Features control panel, selecting 
Octopus USB Controller and then selecting “uninstall”. 

• Install OUC on your new machine and once installed enter the activation code in the License 
Activation Data screen. 

• Click “Activate” to complete the activation process 
 
Lost activation code:  If you have a computer melt-down and need to reinstall OUC from scratch on a 
new computer, you will need your activation code.  This was likely sent to you from your reseller and 
should be contained within an email.  If you cannot find the activation code, please contact your 
reseller. 
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Support: Support of OUC is provided on a complimentary basis for two years following your purchase.  
Initial support is provided by the reseller from which you purchased your activation code.  SpeechWare 
is very interested in knowing if you identify an incompatibility or bug and such issues can be reported 
directly to SpeechWare by means of the functionality reached at Tools > Report incompatibility or 
problem … 
 

General Instructions for Use: 
 
General Set-up and Usage: 
 
Using OUC requires that it be started.  If you desire, you can set the application to start automatically 
each time you reboot your computer (see options menu).  Before you can use OUC you need to do the 
following: 
 

1. Complete installation as detailed above 
2. Plug in your compatible USB device either before or after starting the utility.  Actual 

programming for your specific device cannot take place until after the USB device is attached 
and recognized by Windows and OUC. 

3. Launch OCU from the Windows Start Menu or from a desktop icon; by default it will appear only 
in the tool bar – show the full application control window by right clicking on the toolbar icon 
and selecting View > Floating Window 
 

USB microphones, foot pedals, TableMikes: Assuming you 
have a compatible device connected, it will be automatically 
detected and will show up as a connected device on the 
“Active USB HID Device to configure” dropdown on the main 
OUC screen.  Connected active devices will be shown in the 
upper area of the drop-down and in bold font, while the list of 
non-detected devices is grayed-out and listed below. 
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If you select your device from the drop-down menu, you 
will see a visual representation of your device (see 
adjacent image which demonstrates appearance of 
connected Nuance/Dictaphone PowerMic II).   

 
If you have multiple devices attached, they will all be 
sensed by OUC and will work, although you will need to 
select your device from the “Select Device” drop-down 
menu in order to program behavior for that device.  Until 
you program your own behavior for each button or pedal 
on each device it will follow the default behavior chosen by 
SpeechWare.  
 
Keypads:   Keypads are seen and programmed by selecting 
“Active Keyboard & External Keypads” from the Active USB HID Device menu.  Until you actually 
program a key (described in detail below) you will not see a representation of the individual keys on the 
device. 
 
Non-recognized devices:  If your device is not one which is pre-programmed by SpeechWare it will not 
show up on the drop-down menu and will need to be “learned” by OUC using the “AutoLearn” 
functionality described below. 
 

Launching Dragon NaturallySpeaking:  If you are planning to use OUC with Dragon, you can 
launch it at any time, using the normal method for launching Dragon from the Start Menu, desktop 
shortcut, etc.  If Dragon isn’t launched when you launch OUC the only consequence is that any buttons 
on your device programmed for Dragon-related functions will be grayed out and will not work until you 
launch Dragon.   
 

Programming a key on your USB Microphone or Foot Pedal (see separate instructions 
for programming a USB keypad):   
Once your USB device is selected from the Active USB HID Device drop-down menu you will see that 
each button on your connected device is assigned a name on the left-hand column of the main OCU 
application window.  Directly to the right of the name column is the list of currently assigned actions for 
each button.  If you are uncertain of where a specific button on your device shows up on the list, simply 
push the button on your hand-held device or foot pedal and the associated line will be highlighted.  
                 
Follow these basic steps to program a button (more detailed information on each programming function 
is shown later in the User Guide): 

 
• Double click on the line associated with the button you wish to program.  This will open the 

“USB Device Settings” window shown below.  Alternatively, you can select the button to be 
programmed and click on the “Edit” button. 
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• You will see there are 8 categories of button assignment: 
 

 
 

o Boilerplate Text: add text into the area and then with a single press of a button or pedal 
it will be inserted at the cursor location in any word processing application or text 
window. 

o Dragon Commands:  this is the area where you can assign a number of pre-configured or 
user-defined dragon commands to a button push.   
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o Dragon hotkeys:  this is a series of functions which can typically be assigned from the 
Dragon Options > hotkeys menu and include programming a button to turn the 
microphone on/off, open the dictation box, etc. 

o Keyboard Emulation:  this area allows you to program a key depression on your USB 
device to emulate a single key or key combination.  It includes the modifiers alt, shift 
and ctrl 

o Launch:  this allows you to assign opening of a program, document, folder or web-page 
to a button push/pedal push. 

o Windows:  Use this tab to access programming of a series of Windows related activities, 
including resizing windows, opening the Task Manger, opening the Control Panel, etc. 

o Custom Script: this is a series of actions that you can execute sequentially. Add or 
remove from the list as you wish. 

o Advanced:  this tab allows assignment of separate functions to the depression and 
release of a button, lever or key. 

 
• Select the tab/category based on your preference 
• Select the specific function your desire to assign to a button 
• Click OK 

 

Programming a key on your On-Board Keyboard or USB Keypad:  This process is slightly 
different from programming other USB devices.  Follow this basic procedure: 
 

• If using an external keypad, it should be connected and you must wait until all drivers are 
installed by the operating system (not necessary if programming a key on the on-board 
keyboard) 

• If not already selected, from 
the Active USB HID Device drop 
down on OUC select “Active 
Keyboard & External Keypads”.  
You will see a representation of 
a keypad, as shown below.  
Before any programming is 
initiated you will not see any 
keys or actions listed. 

• Program a key as follows, using the image below as both a guide and example of how 
programming will appear: 

o Click “add” to initiate programming.  You will see the dialog box shown below to 
indicate the next step. 

o Depress the key on 
your on-board 
keyboard or external 
keypad you wish to 
program.  As soon as you do, the full “USB Device Setting” window will appear, from 
which you can choose the desired programming, just as with other external USB 
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devices described above.  Once keys are programmed, your device may look as 
shown below. 
 

 
 

Previously created behavior for a key on a keypad can be modified by double-clicking on the line 
associated with the button or highlighting the line and clicking “Edit” 
 

Programming a Device Not Recognized by OUC 
 
If you are attempting to use a USB device which is not recognized by Octopus USB Controller, it is 
necessary to manually add the device using the “AutoLearn” functionality.  This works as follows: 
 

• Attach the device to an available USB port 
and be sure all drivers are installed 

• Navigate to Tools > Options and select 
the “AutoLearn” tab 

• Click on the “Start Configuration” button 
• Sequentially press on each button or 

lever on your attached device, looking to 
see that the small red indicator briefly 
flashes green with each press to indicate 
that the event was recognized 

• After each of the buttons have been 
pushed, click on the “finish configuration” 
button. 
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If for any reason you cannot control a new device using the AutoLearn method, it is possible to send 
your device information to SpeechWare and they will, in turn, create the necessary programming to use 
this device.  This is done using the “Report Incompatibility or Problem …” function from the tools menu.  
Details of this method are described in the section titled “Non-compatible devices” in the Appendix of 
this guide. 
 

Details on Assigning Functions to Buttons: 
 
Boilerplate Text: Assigning a 
button or lever on a USB device to 
insert boilerplate text is a useful 
function if there are certain chunks 
of text (single words, phrases, or 
longer passages) that you use 
regularly and may want to insert 
into a word processing document or 
text entry window on a regular 
basis.  Examples include a signature 
line, an email address, or perhaps a 
password.   
 
Setting up boilerplate text entry is as easy as choosing the Boilerplate text tab and by any means you 
choose entering this text into the main window – see adjacent image. 
 
Note:  At this time it is not possible to add formatting to text used in the boilerplate command.  This is a 
functionality expected during a future upgrade. 
 
 

Dragon Commands:  This series of choices allows you 
to program your USB device to activate specific 
commands for users of Dragon NaturallySpeaking, 
including both intrinsic (built in) commands and 
personalized commands you have created.  It comes with 
a series of common commands which can be directly 
chosen.  Alternatively, you can select the top choice 
(“Type below the exact name of the Dragon Voice 
Command …) and enter the exact command name below, 
and this will initiate the command as if it was enunciated 
aloud. 
 
Current Dragon Commands in OUC: 
 



User-defined Dragon Voice Command* 
All caps off 
All caps on 
Capitalize that 
Caps on 
Caps off 
Correct that 
Format that all caps 
Format that bold 
Format that italics 
Format that regular 
Format that underline 
Go to sleep 
Next field 

Numbers mode off 
Number mode on 
Play that back 
Previous field 
Scratch that 
Select that 
Spell mode on 
Spell mode off 
Spell 
Transfer text 
Underline that 
Unselect that 
Wake up

 
*User-defined Dragon Voice Command allows assigned any existing user-created Dragon command to a 
button, key, etc.  When assigning a “user defined” command, it is important that you enter the word or 
words with the proper case (capitalization).  If in doubt about what Dragon is expecting, issue the 
command by voice and then go to the Words menu and select “View Recognition History …” to see 
exactly how the word or words are formatted.  Copy this when entering the command name into OUC.  
 
Notice that many of the Dragon commands are for specific events that you probably won’t want to 
continue indefinitely, such as “all caps on”, “number mode on”, etc.  For these types of commands you 
may want assign separate functions to a key depression and release, for example assign the depression 
to “numbers mode on” and the release to “numbers mode off”.  In this way, you can have dragon enter 
a specific mode only during the depression of a key, button or lever and that action or mode will end 
with the release of key. 
 

Dragon Hotkeys:  These are a series of Dragon functions which can traditionally be assigned to a 
keyboard key from Dragon’s Options > HotKeys menu.  Included within this category are all the 
functionalities provided in the Dragon Hotkeys menu, including: 
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Microphone on/off 
Fast forward 
Force command recognition 
Force dictation recognition 
DragonBar menu 
Microphone sleep/on 
Press-to-talk 
Dictation Box 
Playback 
Next field 
Previous field 
 

Keyboard Emulation:  This is a very helpful functionality useful if the application you are using (an 
electronic medical record, for instance) allows for certain functions to be initiated with a keystroke or 
key combination.  Follow this procedure to assign a key combination to your USB device: 

 
 

 
 

• Select the Keyboard Emulation tab 
• Click on the “Change keys …” button.  This will cause the Change Keys options box to 

open. 
• Type the key or key combination using your actual keyboard and it will show-up in the 

text box in the Change Keys options box 
• If the key or key combination is not available on your actual keyboards, you can click on 

the small virtual keyboard shown above and it will open a much larger virtual keyboard 
from which you can choose addition keys and key combinations. 
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• As needed, click the boxes next to “Control”, “Shift”, and “Alt” for key combinations.  
These boxes will be check automatically if you use these actual keys when assigning a 
key combination. 

• When done, click OK 
 

Note on Assigning Keys and Key Combination:  If you are running a program running via Citrix, you might 
find some keys and key combinations created through OUC will not transmit to the application on the 
Citrix server.  In such a situation you may want to experiment with other methods of doing so.  We have 
found, for instance, the F2 or shift + F2 combination to move through “wildcard” navigation points in 
Epic won’t work with Keyboard emulation.  Rather, we create a step-by-step command in Dragon and 
then initiate this command with OUC.  It works perfectly. 
 

Launch:  The Launch functionality is highly useful and allows you to assign a button push or pedal 
depression to opening a program or even a specific document.  Setting up such behavior is fairly 
straightforward once you choose the “Run” tab under USB Device Settings.  You are given the choice of 
opening a program or opening a specific document.  See overview below: 

 

 
 

Open Application:  If you want to program a button to open a program, select the radio button 
next to “Application” and then click to the “Explore” button to navigate to the specific 
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executable file (usually found in C:\Program Files(86)\ or C:\Program Files.   Optionally, if you 
understand command line arguments and want to add an argument to your open application 
request, add this to the “Arguments” text entry box. 
Open Document:  If you want to open a specific document or file, select the “Document or file 
…” radio button and then click on the “Explore” button to navigate to the specific document or 
file. 
Open Folder:  Program the opening of a specific folder using the same general method used for 
applications and documents by selecting the “Folder” radio button and navigating to the folder 
of interest. 
Open Web Page:  although there is not a radio button for this functionality, you can program 
the opening of a specific webpage by simply pasting the URL into the text box to the left of the 
“Explore” button. 
 

 
 

With any of the above methods, you can select an “Execution Mode” from the dropdown and have the 
choice of Normal, Hidden, Minimized and Maximized. 
 
Note on the Run functionality:  as with the insertion of a web page, if you know the exact location of the 
application, document, or folder, you can enter this directly into window to the left of the Explore 
button. 
 

Windows Functions:  OUC offers the ability to assign to a key or button push any of a series of 
Windows operating system functions, including: 
 

Switch Window (next) 
Switch Window (previous) 
Open Control Panel 
Open Task Manager 
Open Calculator 
Open Power Options 

Open Windows Explorer 
Open Devices and Printers 
Maximize Window 
Restore Window 
Clear Desktop

Hint:  if there are other Window functions you want to assign to a button, there are a series of 
“keyboard shortcuts” built into every Windows operating system to allow this.  You can use the 
“Keyboard Emulation” function of OUC to create such behavior by programming the key combination.  
Please refer to the references in the appendix of this guide for more information on Windows shortcuts.   
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Custom Script:  This is useful if you desire to set in motion a series of steps with a single button push 
or pedal depression.  The possibilities are endless and each individual step can include any of the actions 
programmable with OUC.  It is possible, for instance, for a single button push to open Microsoft Word, 
insert specific boilerplate text, to open the print menu and to press enter key and then to close the 
document. 
 

Creating a custom script is as 
simple as opening the custom 
script tab, clicking “Add” to create 
your first step, adding steps 
sequentially, reordering them as 
needed using the up and down 
arrows, and then clicking OK.  See 
example of the script described 
above in the figure below: 
 
A few caveats on creating scripts: 

o Sometimes it is necessary to add a slight delay after one entered step to allow it to 
complete before firing the next step.  Opening a program, for instance, might require a 
second or two.  In such cases you should enter a short “Wait” command to effect a 
slight pause as the script is running. 

o Once a script is designed, you can alter the order of the steps within the script by 
selecting a specific step and then pressing the up or down arrow key to alter the 
position of the step. 
 

Advanced:  the “advanced” tab provides you the ability to assign separate programming to the 
depression and release of any button, key or lever.   Adding this type of behavior to a button, key or 
lever press is similar to all other OUC programming.  The appearance of the Advanced tab is shown 
below. 
 
Programming of separate press and 
release behavior is particularly useful 
if you want something to happen only 
transiently (while pushing a button 
for instance) and then ended when 
the button is released.  This type of 
behavior is especially suited to 
Dragon users who wish to 
temporarily put Dragon into certain 
“modes” such as: 
 

• Numbers mode 
• Spelling Mode 
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• Caps mode 
• All Caps mode 

 
This type of programming is not limited to use with Dragon.  In fact, you can assign ANY function 
programmable with OUC separately to a button press or release. You could, for instance, assign a press 
of a button to open a program or document and the release to close it, if you wanted to simply gaze at 
the document briefly for a reference. 
 

Legal Keyset Programming (Legal version only) 
 
In consideration of the unique word-processing demands of the legal professional, SpeechWare has 
included in the Legal version of OUC a category of programming that allows a user to program a key on 
the standard keyboard or accessory keyboard, functions which are frequent used and often slow to 
institute.  Although a few of these potential “commands” simply involve unusual characters, many 
pertain to setting specific options in Microsoft Word. 
 
Keep in mind that these commands are, in effect, asking OCU to press a keyboard key or key-
combination when you press a single key.  If you have not already purchased the legal version of OUC 
and need some of these functions, refer to the table of Microsoft Office shortcuts in the appendix of this 
guide and consider programming some of these commands yourself using the hot-key functionality.  The 
advantage of purchasing the Legal version is having the most commonly used Word programming 
already installed. 

 
 

Altering Octopus USB Controller Desktop Appearance and Start-up 
 
By selecting one or more options from the OUC “View” menu, you can alter the appearance and 
behavior of the application on your desktop. 
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Start-up:  On initial installation, an icon to start OUC will be placed both on your desktop and 
Start menu.  In this scenario you must start each session of OUC by selecting it from one of 
these locations.  If you prefer to have OUC start automatically each time you boot-up your 
computer, this can be accomplished by navigating to Tools > Options and placing a check-box 
next to “Run on Windows startup” 
 

 
 
 
View:  You can also alter the behavior and placement of the main UOC controller window from 
the view menu.  Options include: 

o Floating Bar:  This will show OUC as a full-sized window on your desktop 
o Reduced:  When in the “reduced” view, OUC is visible on the desktop but only the actual 

programmable keys for your device are shown.  See graphic below. 
 

 

 
 
 
 

 

Floating View Reduced View 
 

o Tray Icon Only:  This places an icon for OUC in the Windows Taskbar.  While in this mode 
you can right click on the icon to access the Profile, View and Help menus 

o Always on Top:  If you choose this mode, the OUC window will remain on top of all other 
active windows.  Most users will probably NOT want to select this mode since it takes up 
space on your desktop. 
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Exporting and Importing User Device Configuration Profiles 
 
In many ways, the details of the programming you have set up for your devices with Octopus USB 
Controller become a valuable asset.  Consequently, you may want to archive your current device 
configuration profiles for reference, or transfer (import/export) for back-up, transfer to another PC or 
sharing with a colleague.  For an institution or group of users, the ability to set up a new OUC user with a 
complete set of customized device profiles can be huge time saver.  To facilitate these functions, OUC 
includes the ability to perform the following: 
 

• Export all device settings 
• Import all Device settings 
• Print Device settings  
• Print all device setting 

 
All of these functions are accessed through the OUC “File” menu as shown below and are fairly intuitive. 
 

 
 

Dragon Template/Field Navigation Functionality 
 
The ability to navigate through a document by voice and the creation of “Dragon templates” or “variable 
fields” is a highly useful functionality seen in Dragon Professional, Legal and Medical.  This functionality 
works by navigating to the next instance of a pair of field delimiters which, by default are a left and right 
squared bracket (“[“ and “]”).  Navigation through a series of Dragon templates can be done in a forward 
or backwards manner and are accomplished by saying “next field” or “previous field” and this command 
can also be initiated by a button push by assignment of a Dragon “hotkey” from the Tools > Options 
menu.  Use of this functionality is highly useful when creating letters, notes, and other documents that 
share common regions and in which you simply want to navigate to different locations for dictation of 
specific variable text. 
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Octopus USB controller offers two means of extending the use of Dragon Templates: 
 

1.  OUC can be used to program the command “next field” or “previous field” to any button, key or 
lever by choosing this from the “Dragon Commands” tab on OUC.  It should be noted that this 
native function is operational only in Dragon Professional, Legal and Medical versions. 

2. OUC extends the use of “next field” and “previous field” commands to the Premium version of 
Dragon when used in Microsoft Word. 
 

Utilizing the Dragon Microphone Indicator/Controller Functionality 
 
As an added feature for Dragon NaturallySpeaking users, SpeechWare has added functionality to 
Octopus USB Controller to assist in microphone management.  This feature provides you with the option 
of placing a “microphone status indicator” on the desktop to provide a more obvious indicator of the 
microphone on/off/standby status as follows.  Configurable options include: 
 

• Presence or absence of icon 
• Icon size 
• Icon transparency 
• Microphone on/off/standby status 
• Microphone icon position (can be 

dragged anywhere on screen) 
• Microphone icon as a controller of 

controller of Dragon microphone 
(actuated with a mouse click over the 
icon or touch on a touch-sensitive 
screen or tablet) 

 
All of the above features and characteristics are 
controlled from the “Microphone Icon” tab of 
the OUC Options menu (reached through Tools 
> Options > Microphone Icon), which is shown 
in the image at the right. 
 
 
Appearance of Microphone Status Indicator buttons: 
 

   
Microphone Off Microphone On Sleep Mode 
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Size Options for Microphone Status Indicators:  Sizes between 5 and 1080 pixels can be chosen and 
representative sizes are shown below: 
 

55 Pixels 155 Pixels 205 Pixels 

 

 

 
 
Opacity/Transparency:  In order to avoid blocking key underlying applications, you can alter the 
transparency of the microphone status indicators, varying from 10% (most transparent) to 100% (most 
opaque).  The relative change is shown below. 
 

Opacity 10% Opacity 50% Opacity 100% 

   

Appendix 
 

Compatible Devices:  The following USB foot pedals, hand-held microphones and other devices are 
known to be compatible with the Octopus USB Controller and will provide device specific information 
when programming: 
 

USB Foot Pedals 
Buddy/Insync FootSwitch 7G 
Buddy/Insync ElbowSwitch 7G 
Certified Transcription Aid Pedal 
Grundig Digta Foot Control 538 USB  
Grundig Digta Foot Control 540 USB  
Grundig SoundBox 830 USB  

Infinity IN-USB1* 
Infinity Foot Control IN-USB-2  
Infinity Foot Control IN-SRW  
Olympus Foot Switch RS27  
Olympus Foot Switch RS28  
Olympus Foot Switch RS31  
Philips Foot Control LFH 2320  
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Philips Foot Control LFH 2330  
SpeechWare USB Single Foot Pedal (under 
development) 
SpeechWare USB Triple Foot Pedal (under 
development) 
Xkeys USB 
 

Hand-held USB Microphones: 
 

Buddy StylusMic 
Grundix Digta CordEx 
 
Grundig SonicMic 3 
Nuance PowerMic II 
Nuance PowerMic III 
Olympus DR-1200 
Philips SpeechMike Air LFH3000 
Philips SpeechMike Classic 6264  
Philips SpeechMike Pro 5276  
Philips SpeechMike LFH3500/00 
Philips SpeechMike LFH 3510  

Philips SpeechMike Classic 6264  
Philips SpeechMike 6274 
Philips Speechmike Pro 5276  

 
Desktop USB Microphones (Volume Up/Down 

buttons): 
 
SpeechMike One 
SpeechWare USB 3-in-1 TableMike 
SpeechWare USB 6-in-1 TableMike 
SpeechWare USB 9-in-1 TableMike 
 

USB KeyPads:  All tested keypads have been 
found to be compatible with OUC. Specific 
button functionality is not seen until a button is 
programmed. 
 
*Recognized as an Infinity IN USB2 but programs 
normally. 

 

 

Non-Compatible Devices: reporting a non-compatible device to SpeechWare 
 
Octopus USB Controller has been programmed to be compatible with most commonly used USB hand-
held microphone and foot pedals.  If you have a device which is not compatible, it can still be used by 
employing one of two methods: 
 

• Utilizing the “AutoLearn” methodology described earlier in this guide. 
• Using the “Report incompatibility or problem..” functionality from the Tools menu. 

 
Here is the method by which you can report an incompatible 
device 
 

1.  Select “Report incompatibility or problem …” from the 
Tools menu 
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2. When opening this functionality, you will first be greeted with the following recommendations 
which you are encouraged to follow before 
proceeding: 
 
If following these steps does not resolve the issue, 
then continues as follows: 
 

3. If the issue does not have to do with an 
unrecognized USB device, you should fill out the 
form that comes up, describe the problem, check 
the box which will facilitate attachment of the 
application logs, and then click on the “Send” 
button. 

4. If you have an unrecognized USB device, you have the option of sending to SpeechWare the 
pertinent information regarding the device so they can add needed programming to make the 
device recognized for you and other users.  In order to start this process, click on “Check USB 
Device”.  

5. Using the resulting dialog box, map the 
keys on your USB device by following 
these steps sequentially: 
 

a. Click on the start button 
b. Enter the name of the key you 

plan to click 
c. Push and release the key you 

have named 
d. Follow steps b and c for every 

button or key on the device 
e. When done click on the “Close 

and attach” button 
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Windows Shortcuts: 
 
Additional behavior can be assigned to a button by using the Keyboard Emulation tab and use of 
standard “Windows Shortcuts” which are keyboard shortcuts built into Windows operating systems to 
allow simplified access to commonly employed functions.  Information on shortcuts can by found by 
searching “Windows keyboard shortcuts” or visiting an extensive table of shortcuts on Wikipedia at:  
http://en.wikipedia.org/wiki/Table_of_keyboard_shortcuts   For an extensive overview of hotkeys 
related to a number of applications, consider visiting All Hotkeys at http://allhotkeys.com/  
 

Microsoft Word Shortcuts 
 
Like most applications, Microsoft Word allows for many functions to be emulated with simple keyboard 
shortcuts.  These shortcuts can be assigned to hand-held microphones, the buttons on a TableMike, any 
single keyboard on your computer’s keyboard, and the levers on a foot pedal.  When it comes to 
assigning hot key function to a keyboard key, keep in mind that this behavior, once assigned, will 
substitute for the normal function of the key, so don’t assign such behavior to keys you are likely to use 
for their natively assigned function. 
 

http://en.wikipedia.org/wiki/Table_of_keyboard_shortcuts
http://allhotkeys.com/
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Below is a partial list of keyboard hot key functions available in most recent versions of Microsoft word: 
http://allhotkeys.com/ 
 
 

Working with Microsoft Excel: 
 
As with Windows in general, there are many shortcuts which allow navigation and functioning within an 
Excel spreadsheet with hotkeys. This becomes an easy process to emulate with a button, key or lever 
push using OUC.  For a list of common shortcuts, we recommend you visit any of the links below: 
 

• http://office.microsoft.com/en-us/excel-help/excel-shortcut-and-function-keys-
HP010073848.aspx 

• http://www.stanford.edu/dept/EHS/prod/general/ergo/documents/Excel_Specific_keyboard_s
hortcuts.pdf  

 
For example, one might need to repeatedly open a specific Excel document and navigate to a specific 
cell within the document.  This can be accomplished using a “Script” in which the following actions take 
place: 
 

1. Run command opening the document you desire 
2. Optional short “Wait” 
3. Key emulation of F5 (opens the Excel “Go To” dialog box) 
4. Boilerplate text to enter the  cell location (column followed by row, i.e. A5, F33, etc.) 
5. Key emulation of a “Return” or “Enter” key 

 

Location of Common Programs/Executable Files 
 
If you are seeking to initiate the opening of a specific program with functionality facilitated by the Run 
tab, you will need to navigate to the executable file for the application.  Most of these are contained in 
the C:\Program Files (x86)\ folder which is shown by default when you “explore” for a program for OUC.  
Not so obvious is where some programs are located within this folder.  Here are locations for some 
common applications: 
 

Google Chrome:  C:\Program Files (x86)\Google\Chrome\Application\chrome.exe 
Internet Explorer:  C:\Program Files\Internet Explorer\iexplore.exe 
Microsoft Excel:  C:\Program Files (x86)\Microsoft Office\root\Office16\EXCEL.EXE 
Microsoft PowerPoint:  C:\Program Files (x86)\Microsoft Office\root\Office16\POWERPNT.EXE 
Microsoft Word:  C:\Program Files (x86)\Microsoft Office\Office16\root\WINWORD.EXE 
NaturallySpeaking 12:  C:\Program Files 
(x86)\Nuance\NaturallySpeaking12\Program\natspeak.exe 
WordPad:  C:\Program Files (x86)\Windows NT\Accessories\wordpad.exe 
WordPad:  C:\Program Files\Windows NT\Accessories 

http://office.microsoft.com/en-us/excel-help/excel-shortcut-and-function-keys-HP010073848.aspx
http://office.microsoft.com/en-us/excel-help/excel-shortcut-and-function-keys-HP010073848.aspx
http://www.stanford.edu/dept/EHS/prod/general/ergo/documents/Excel_Specific_keyboard_shortcuts.pdf
http://www.stanford.edu/dept/EHS/prod/general/ergo/documents/Excel_Specific_keyboard_shortcuts.pdf
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A simple way to find the location of a program is to enter the name in the “Search programs and file” of 
the Start Menu and if you see the program, rather than clicking on it, right click on the program and 
select “Open File Location” 

Opening Browser with Pre-specified Search 
 
If you have a reason to open a browser very regularly and with a pre-defined search topic, this can be 
programmed into a “Run” behavior assigned using OUC.   
 
Bing:  www.bing.com/Search?q=term1+term2 
Google:  https://google.com/#q= term1+term2+term3 
 

Sources of Additional Information: 
 

http://www.tablemike.com/en/download-applications.php  
http://OctopusUSBController.com  

 

 Caveats on Using Octopus USB Controller 
 

 If your USB device has dedicated controlling software which is also running, you may find 
erratic behavior since button pushes may be initiating action through both OUC and the 
other controlling software.  In such a situation we recommend that you either turn off or 
uninstall the other device controlling software.  If you absolutely need that software, then 
you should be sure to configure the other software not to control any buttons you desire to 
control with OUC. 
 
The Buddy/Insync StylusMic has two buttons which can be programmed.  The top-most 
button (nearest the microphone) is programmed by default to turn the microphone off and 
on.  If you wish to have the behavior defined by OUC and not the default behavior, we 
recommend that you use the Insync “MyBuddy” software to turn off the default behavior 
of the device. 

 
 
 
Revision: 7.31.17 

http://www.tablemike.com/en/download-applications.php
http://octopususbcontroller.com/
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